This project is read-only.

Did I miss something?

Topics: User Forum
Jan 8, 2009 at 8:02 PM
I tried to build the dotnetscorm package according to the install docs and I'm getting an error. I'm reposting here in case KentWA is busy.

I'm running the install.aspx from VS2005 running on XP under IIS5.1

Do I need to build the clubsite first?


---

<title>Compilation Error</title> <style> body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } </style>

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0234: The type or namespace name 'API' does not exist in the namespace 'ClubSite' (are you missing an assembly reference?)

Source Error:

Line 8:  using System.Web.UI.WebControls.WebParts;
Line 9:  using System.Web.UI.HtmlControls;
Line 10: using ClubSite.API;
Line 11: 
Line 12: /// <summary>

Source File: c:\Inetpub\wwwroot\dotnetscorm\DotNetSCORM.WebSite\App_Code\CSCode\SiteSettings.cs    Line: 10
---
Jan 11, 2009 at 10:54 PM
I am not sure just why yet, but for some reason you have to do 2 builds from VS2005. Just build the project, then rebuild and it should work. I had this very issue a little over a week ago when I did a test setup on a clean Virtual Machine.